Upgrade Swarm64 DA

Instructions to upgrade Swarm64 DA.

Swarm64 DA versions are tied to specific EPAS minor versions for compatibility. Check the release notes to know when you need to upgrade the minor version of EPAS.

  1. Upgrade the corresponding Swarm64 DA package for your operating system and EPAS installation.
    Ubuntu/Debian and EPAS 12
    sudo apt-get update
    sudo apt-get install --only-upgrade swarm64da-epas-12
    Ubuntu/Debian and EPAS 13
    sudo apt-get update
    sudo apt-get install --only-upgrade swarm64da-epas-13
    CentOS and EPAS 12
    sudo yum update swarm64da-epas-12
    CentOS and EPAS 13
    sudo yum update swarm64da-epas-13
  2. Restart EPAS.
  3. Switch to a user with access to the database:
    sudo su - enterprisedb
  4. Connect to the database:
    edb-psql -d postgres
  5. Upgrade the Swarm64 DA extension:
    ALTER EXTENSION swarm64da UPDATE;
    Execute this step in each database of your installation that uses Swarm64 DA. Columnstore indexes are updated automatically when necessary. During the update, which may take up to several minutes, the columnstore index performance may be temporarily reduced.
  6. Verify that the Swarm64 DA extension is loaded correctly and look up its version number:
    SELECT * FROM swarm64da.get_version();